Unable to register TakeCommand

Nov 4, 2009
Hello, a few days ago I bought a new license of TakeCommand version 21, but I am having trouble registering it.

The error message is:
[11004] Valid name, no data record (check DNS setup)

This is for my work laptop. I tried both when connected to the corporate network and when connected to my home network. I also tried adding the corporate proxy under settings, but I get the same message.

I bought some additional software from another vendor and had no issues activating it.


Staff member
May 14, 2008
Something (either a proxy, Windows policy, or third-party app) is blocking TCMD from accessing the registration server.

You can try a manual key (which does not require internet activation) by going to the Register dialog, entering your activation key, and then clicking on the "Request Manual Key" button.
Nov 4, 2009
Thank you, I clicked "Request Manual Key" and was directed to a webpage which had my license key already filled in and "Computer ID" was also requested. I made one up myself and generated a key, but when I use it, I get the same error message: [11004] Valid name, no data record (check DNS setup). I guess I made a mistake with the "computer id"? There were no instructions on the page. Please advise
Nov 4, 2009
It worked now when I tried the again using the Computer name. Registration successful. How does unregister work when I no longer have this computer and want to move my license to a new system?
Similar threads
Thread starter Title Forum Replies Date
Eric Peters New Computer, unable to register Support 3
A Unable to register TC23 Support 1
W Unable to register TCMD v21 Support 16
Y Unable to register v13. Support 1
N Unable to bind multiple keys to the same key mapping directive Support 9
A Unable to pass batch file arguments unaltered Support 18
D Unable to uninstall TCC 21 Support 1
G How to? Unable to install TCMD 21 under Win2012R2 Support 5
dcantor Unable to access help Support 9
WavSlave Fixed Unable to sort files by description in TCC v19 Support 2
nickles WAD del unable to delete files ending in "." Support 18
R Unable to start any BTM file from Explorer Support 5
M I'm unable to use @replace[] with a % character in string2 Support 12
Jay Sage Unable to Specify INI File Support 19
thedave WAD Unable to type various characters using Windows 8's onscreen keyboard Support 7
Dan Glynhampton Fixed @version "force" flag not working, and unable to set separator Support 3
D ftps gives "Unable to build data connection" Support 5
M Why am I unable to delete files? Support 8
Y Unable to close v13 Support 26
N Unable to end tcc.exe process Support 1
Y Unable to install 10.00.50 Support 3
P Take Command 24 will not register Support 2
P How to? Register offline? Support 1
John Daly can't register TCC Support 14
Alpengreis How to? Installed v18 Beta - how buy/register? Support 2
fishman@panix.com Do you really have to be connected to the Internet to register? Support 1
SB-Robert Old 4NT Won't Register - Options? Support 8
Phileosophos Fixed Register for all users doesn't register for all users Support 10
S How to? Register all JPsoft products at once Support 1
joltcoder Receiving timeouts when attempting to register software. Support 4
ehab aboudaya Random Register reminder on new tab annoyance Support 4
fishman@panix.com How do I buy and register Version 15? Support 6
vefatica IsLicense50.dll failed to register Support 14
millardjk Register TC13 for all users? Support 12
S Cant register version 13.00 Support 4
C Cannot register v12.10 without Internet access Support 19
K Refuses to register Support 3
noahcoad Register from Command Line Support 1
mscheuner TCMD 8 - cannot register on Vista x64 Support 0
samintz Starting Terminal from TakeCommand Support 3
H Takecommand.pdf failed not a pdf file Support 6
AndrewJ TakeCommand v23 + ANSI color sequences leads to black on black text Support 6
vefatica Permanently registering TakeCommand v8.02.106? Support 17
C "TakeCommand has stopped working" Support 3
P Access denied TakeCommand.19.0.key Support 2
nickles Move takecommand.18.0.key location to installation directory Support 4
C TakeCommand 18 Installation Failure Support 13
Phileosophos TakeCommand exits after launching TortoiseHg Workbench Support 4
mikea TakeCommand "evangelism" -- how? Support 1
Stefano Piccardi can start TakeCommand 15.01 on Windows XP Support 6

Similar threads