WAD Unable to type various characters using Windows 8's onscreen keyboard

Nov 13, 2008
I recently purchased a Microsoft Surface Pro 3, which uses an on-screen keyboard as well as an optional physical keyboard.

When using TCMD, I'm unable to type various characters using the Windows 8 on-screen keyboard, including : and " -- In general, any punctuation that would need you to hold shift to type.

If I switch to TCC, punctuation works normally.

You should be able to reproduce this on any Windows 8.1 machine by enabling the "Touch Keyboard" toolbar of the Windows Taskbar and then clicking on the touch keyboard icon.

Everything works when using the physical keyboard.

TCC 16.03.55 x64 Windows 8.1 [Version 6.3.9600]
TCC Build 55 Windows 8.1 Build 9600
Nov 13, 2008
I've also confirmed that this can be re-produced using the Touch keyboard on a non-touch desktop-only environment, so no special hardware is required to troubleshoot this, just a modern OS.


Staff member
May 14, 2008
Unfortunately, the bug is in Microsoft's code. They've known about it for a while, but since it only affects apps that forward keystrokes to other apps, they're probably not too concerned. Unless Microsoft sends me the source code, there's not much I can do about it.
May 30, 2008
Gerakas, Greece
  1. It's not exactly like this. Some symbols get translated to other symbols. Specifically, symbols that should be shifted (for example the double quotes (") or the exclamation mark (!)) are passed to the underlying console as unshifted (specifically as single quote (') and the digits one (1) respectively). It seems as if the shift state is lost (or perhaps it's read from an irrelevant place, such as the true shift state at the time, or by using a different API than is supposed to be used).
  2. There is a perfectly good workaround, using the on-screen keyboard in the "full" mode, instead of the "compact" mode (the last mode in the mode list).
  3. That being said, it *should* be possible for Take Command to pass the correct character to the backend, as can be demonstrated by some of the "Windows Console Replacement" programs that have been mentioned on JPSoft's blog (I have only tried ConEmu so far, but I'll be downloading and testing more)
May 30, 2008
Gerakas, Greece
Just finished my tests:

  1. mintty: Works (not really surprising, as it isn't really a console application)
  2. Console2: Doesn't work (same as TCMD)
  3. PromptPal: Doens't work (same as TCMD)
  4. PowerCmd: Works
  5. ColorConsole: Works (but the program itself is extremely slow)
  6. ConEmu: Works
Did this ever get resolved? I've just fallen over this issue on a Windows 10 tablet running v18 of Take Command and tried updating to v20 (the most recent version for which I'm licensed) without any improvement. If this is fixed in the latest version it gives me an incentive to lash out on a pair of upgrades.
Similar threads
Thread starter Title Forum Replies Date
N Unable to bind multiple keys to the same key mapping directive Support 9
A Unable to pass batch file arguments unaltered Support 18
Eric Peters New Computer, unable to register Support 3
A Unable to register TC23 Support 1
D Unable to uninstall TCC 21 Support 1
G How to? Unable to install TCMD 21 under Win2012R2 Support 5
K Unable to register TakeCommand Support 4
W Unable to register TCMD v21 Support 16
dcantor Unable to access help Support 9
WavSlave Fixed Unable to sort files by description in TCC v19 Support 2
nickles WAD del unable to delete files ending in "." Support 18
R Unable to start any BTM file from Explorer Support 5
M I'm unable to use @replace[] with a % character in string2 Support 12
Jay Sage Unable to Specify INI File Support 19
Dan Glynhampton Fixed @version "force" flag not working, and unable to set separator Support 3
D ftps gives "Unable to build data connection" Support 5
M Why am I unable to delete files? Support 8
Y Unable to register v13. Support 1
Y Unable to close v13 Support 26
N Unable to end tcc.exe process Support 1
Y Unable to install 10.00.50 Support 3
Charles Dye TYPE /X double-spacing long lines Support 2
Joe Caverly Using TYPE with non-English text Support 22
vefatica TYPE behaving randomly Support 10
vefatica Garbage from TYPE Support 2
vefatica TYPE resets console tab settings Support 14
Joe Caverly Get a variable type Support 2
Joe Caverly v24 TYPE Re-direction Support 4
vefatica TYPE goes crazy with no-BOM Unicode file Support 7
J Piping ANSI control sequences through 'type' Support 4
nickles How to? Follow a JUNCTION type directory link Support 9
S International characters - TYPE vs %@LINE function Support 5
vefatica Fixed TYPE http://... incomplete data Support 40
Phileosophos Documentation TPIPE /string type code confusion Support 4
S WAD %_do_errors does not report errors when loop control variable type is not directory entry Support 1
vefatica TYPE beeping? Support 12
Charles Dye TYPE /P behaves strangely with piped/redirected input Support 0
vefatica LIST and TYPE show UTF8 BOM Support 4
vefatica TYPE, Unicode, installer Support 10
Charles Dye Fixed TYPE /X reports FF for all values >= 80h Support 6
M More SafeChars type issues... Support 4
Charles Dye Strange output, here-doc redirection, TYPE, //UnicodeOutput=Yes Support 6
Roedy MIME type for *.btm ? Support 1
S TYPE command issue Support 12
vefatica TYPE /X and Unicode files? Support 0
dcantor LIST /X and TYPE /X give different results Support 20
Juanma Barranquero App Paths of type REG_EXPAND_SZ Support 2
E colorization outside of type Support 7
p.f.moore Documentation tweak for TYPE Support 5
S Directory history entries from /S option of various commands Support 2

Similar threads