How to? Unable to install TCMD 21 under Win2012R2

Jul 31, 2017
2
0
Today I tried several times to install tcmd 21 under Win7 or Win2012R2. Antivirus was disabled and direct internet access was granted. The server has been rebooted prior to the installation. After unpacking the files the installation stopped while displaying "wait until the installer prepares for installation" (rough translation of the german text) or did not get even so far. Trying older Versions: tcmd 17 and 18 could be installed without any problem. Tcmd 19 had the same problem as 21. What is going wrong ? What are the complete prerequisites for a successfull installation ?
 
Jul 31, 2017
2
0
Tried again: if I am using the tcmd.exe file a windows pops up for a short time saying that the files necessary for the installation will be unpacked. After that nothing happens (job seems to get stuck). I had to kill the tcmd.exe process in task manager.
If I am using the tcmdx64.msi file the installer pops up (see attached picture) but also gets stuck. I will have to wait forever or kill the installer process in task manager. I putted some of the installer logs in the attached zip file.
 

Attachments

  • TCMD21-Installer.png
    TCMD21-Installer.png
    75.8 KB · Views: 120
  • Logs.zip
    12.2 KB · Views: 108

rconn

Administrator
Staff member
May 14, 2008
12,404
152
The installer is hanging in the AI_DetectSoftware call. I have forwarded your logs on to the installer developers, and I will let you know what they come up with.

How long did you wait for the installer to continue? I've seen one or two cases where Windows would hang (on an internal Windows Installer call) at that stage for a minute or two, though not longer than that. Is there any disk activity at that point?
 

rconn

Administrator
Staff member
May 14, 2008
12,404
152
This is what I got back from the installer developers:

---------------------------------

Unfortunately we can't replicate the behavior either, we tried with both EXE and MSI.

From the log, this behavior seems to be related to your software's prerequisites, however I am not sure because the log has an abrupt ending. This may very well be related to something blocking the installer on that particular machine.

You could also look with Event Viewer to see if Windows logged anything significant.

To quicly open Event Viewer try:

• Windows key + R

• type in "eventvwr" then Enter

Look in the Setup and Application sections.

Also try testing on a clean machine with a similar configuration/architecture as your client's. If your attempt is successful, you can rule out anything to be wrong with the installer itself.

Another thing that came to mind: your client can try to install any required prerequisites before running the main installation. If there are any prerequisites already installed on that machine, have him re-install them and then try the setup again.

----------------------------------------------

The TCMD installer does not have any prerequisites. The only thing it's doing before performing the installation is looking to see if Everything Search is running, and if so the installer stops it so it can install the new version. Do you have Everything Search installed? If so, try stopping that manually before running the installer and see if it changes the behavior.

Are you doing an upgrade of an existing TCMD installation, or doing a new install?

Rex Conn
JP Software
 
Similar threads
Thread starter Title Forum Replies Date
Y Unable to install 10.00.50 Support 3
N Unable to bind multiple keys to the same key mapping directive Support 9
A Unable to pass batch file arguments unaltered Support 18
Eric Peters New Computer, unable to register Support 3
A Unable to register TC23 Support 1
D Unable to uninstall TCC 21 Support 1
K Unable to register TakeCommand Support 4
W Unable to register TCMD v21 Support 16
dcantor Unable to access help Support 9
WavSlave Fixed Unable to sort files by description in TCC v19 Support 2
nickles WAD del unable to delete files ending in "." Support 18
R Unable to start any BTM file from Explorer Support 5
M I'm unable to use @replace[] with a % character in string2 Support 12
Jay Sage Unable to Specify INI File Support 19
thedave WAD Unable to type various characters using Windows 8's onscreen keyboard Support 7
Dan Glynhampton Fixed @version "force" flag not working, and unable to set separator Support 3
D ftps gives "Unable to build data connection" Support 5
M Why am I unable to delete files? Support 8
Y Unable to register v13. Support 1
Y Unable to close v13 Support 26
N Unable to end tcc.exe process Support 1
fishman@panix.com 27.00.17 x64 will not install for me!! Support 4
Joe Caverly Here-Document on new Install Support 21
S 32-bit Take Command v22 install for thumb drive Support 1
Roedy install fail Support 9
A Reinstalling TCC-RT 21.01.57 triggers a new install instead of update/reinstall Support 3
R Portable install with v21 - why did it not work? Support 3
samintz Build 38 Install issue Support 5
N Cannot install Support 2
fishman@panix.com Version 21.23 fails to install Support 4
Seven Update / install issue with 20.0.20.10.32 take command Support 7
keithg1964 TCC RT Install Files Support 1
fishman@panix.com Once again the Can't Install bug bites... Support 2
Roedy missing English.dll, failed install Support 2
T Beta - duplicate install Support 7
J How to? 20beta: How to install x86 on x64 Support 2
fishman@panix.com 19.10.51 will not install for me Support 1
A Latest TCC/LE install broken Support 1
M How to? Take Command\TCC install problem... Support 2
H New Install; Everything setup issues Support 9
fishman@panix.com 19.02.37 Does Not Install For Me Support 2
D V19 fails to install on Win7-64bit, installer says: Support 2
Alpengreis [TC 19.0 Beta 22/23] Install/Update-"Problems" Support 4
bwawsc2 Can't install updates to TCMD x64 Support 5
fishman@panix.com 18.00.31 would not install for me Support 5
M How to? Run TCC from Windows Install DVD... Support 2
T Everything install forced (sometimes) Support 2
vefatica Build 28 install Support 8
S How to? Remote Install Support 1
I Take Command 18 x64 Install Hang Support 2

Similar threads