Weird Color Problem

Dec 26, 2009
29
2
No where
I'm probably doing something wrong, but I can't figure out what it is.

Installed the latest version of TCC 28 and started noticing that when I type the following command, or put it in a batch file:
cls bri whi on [color]

It works exactly as expected when I use any of the available colors

Except for this one:
cls bri whi on blu
Which gives me white text on black background instead of blue

Also, I have at least one batch file which uses 'cls bri whi on blu' and it works correctly, while others give me white text on a black background instead of blue.

Weird.
 
Dec 26, 2009
29
2
No where
Standalone TCC console window.

cls bri whi on red
cls bri whi on gre
cls bri whi on yel
....etc

All work exactly as expected.

cls bri whi on blu - white text on black background instead of blue.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,469
88
Albuquerque, NM
prospero.unm.edu
Have you checked your console palette?

Alt-space, P to open the 'Properties' dialog, then select the 'Colors' tab. About a third of the way down, there's a strip of 16 color boxes. The second one ought to be dark blue, but may have been changed.
 
Dec 26, 2009
29
2
No where
Have you checked your console palette?

Alt-space, P to open the 'Properties' dialog, then select the 'Colors' tab. About a third of the way down, there's a strip of 16 color boxes. The second one ought to be dark blue, but may have been changed.
OK. Tried it. Looks OK.

Update: I tried the following:

Open TCC console window
cls bri whi on bri blu (works properly)
cls bri whi on blu (now works properly)

Close TCC console window

Open new TCC console window
cls bri whi on blu (works properly)

So, apparently ........ I "fixed" it ??

Aren't computers fun.
 
Dec 26, 2009
29
2
No where
Update #2

Tried a couple of other batch files that I have sitting around.

cls bri whi on blu
cls bri yel on blu

- results in black background, not blue.

%#$@!!
 
Dec 26, 2009
29
2
No where
I'm not sure exactly what you mean by "separate shortcut". I don't run TCC by navigating to the program directory and clicking on the .exe file. I click on a batch file, which launches TCC and executes the batch file. Or, I right click on a directory and select "TCC Prompt Here" which opens a TCC console window in the directory so I can do whatever.

Anyway, after playing around more with backups, here is what I found:

Reverted my computer to a backup that was running TCC 28.00.11 x64 and it works exactly as expected. cls bri whi on blue results in white text on a blue background.

Although it is still possible that there is some weird mis-configuration on my end, it does appear that somewhere between 28.00.11 and the current version, a small bug was introduced.

This is purely a minor cosmetic issue and it does not affect the actual operation of the program in any way. This is not a complaint. Just a bug report.
 

rconn

Administrator
Staff member
May 14, 2008
12,367
150
TCC does not control displaying characters and colors; that's 100% Windows. (And nothing relevant changed between 28.00.11 and 28.01.14.)

This is most likely a console configuration issue (i.e., using the new vs. legacy console, or ANSI / non-ANSI).
 
Similar threads
Thread starter Title Forum Replies Date
vefatica BEEP - weird on two machines Support 8
JohnQSmith Weird DIR output (missing lines) Support 1
samintz WAD Weird REN bug Support 6
M WAD Another weird copy command errror... Support 2
D WAD Multiple TEE causese weird variable scoping? Support 7
M Weird @Index function result... Support 7
S Weird tab completion in command line Support 2
dcantor Weird interaction with Task Scheduler Support 5
J weird issues in TC10.00.55 Support 4
vefatica ECHOERR and color escape sequences Support 4
gentzel TCMD background color confusion Support 6
M TCC color issue in ConEmu Support 4
vefatica IDE external command syntax color? Support 1
B Problem with color in nested shells Support 1
Alpengreis WAD [v26 Beta RC3]: MSGBOX color problems Support 4
T TCC Window Background Color Anomaly Support 9
AndrewJ TakeCommand v23 + ANSI color sequences leads to black on black text Support 6
K TCC prompt background color Support 4
samintz How to? Screen capture with color Support 13
P Color directories in Win10 build 10586 console Support 11
jbanaszczyk color 00 Support 8
V TCC17 background color problem Support 2
D Highlighted Text Color? Support 2
J Color command and Screen Buffer. Support 2
gschizas (minor) Help topic "Colors, Color Names and Codes" is wrong Support 0
L How to get color into file names? Support 4
fpefpe Color changes Support 1
nikbackm TCMD console color palette Support 4
mscheuner Background color not "sticking" in TCMD v11 x64 on Win7 Support 3
nikbackm TCMD10 tab background color Support 5
A Color in filenames in listview Support 1
fishman@panix.com Problem with 27.15 Support 2
M Problem with VSDevCmd.bat in VS 16.7.3 Support 0
R Problem with @INT[ value] in V26 Support 9
M Selecting test "off by one" problem in Take command Support 4
Alpengreis UTF-8 problem in TCC related to Python Support 7
K_Meinhard Small problem in german IDE 26 Support 3
Joe Caverly Problem creating and switching to a DESKTOP Support 9
vefatica Another popup problem Support 10
Alpengreis ffind dialog (/W) problem Support 4
Alpengreis [TCMD v25.00.24] Small space problem with the DE translation in Prefs-GUI Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
A Problem with functions @int @decimal and identifying Powershell as a shell. Support 12
B IF command problem in tcexit.btm Support 9
fishman@panix.com Problem at Startup of TCC Support 3
P Problem with SFTP copies Support 7
P Problem with FTP copies Support 10
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
R Problem with %_do_loop in nested do loops Support 2
fishman@panix.com New Problem with later Windows 10 Support 10

Similar threads