TCC crashing when copying multiple files (now resolved)

Jun 3, 2008
137
3
Temecula, CA
This is totally new behavior. Ver /r shows:

TCC 16.03.55 x64 Windows 8.1 [Version 6.3.19043]
TCC Build 55 Windows 8.1 Build 19043


My command, executed from the local drive that is to be the recipient of the copy, is

*copy /u /h /e /y /s c:\Temp\Media .

I've been able to do this in the past with no problems. Now, suddenly, after (I think) six files copied, TCC crashes, and a new TCC window is started up. (Update: If I try the equivalent path from another computer connected to this one, with a drive mapped to this computer's C: drive, the copy proceeds just fine, although obviously far slower since it's going over the network. Also, I changed the copy source to fall under my Temp folder.)

Error from Event Viewer, Application log:

- System
- Provider
[ Name] Application Error
- EventID 1000
[ Qualifiers] 0
Version 0
Level 2
Task 100
Opcode 0
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2021-09-27T19:57:33.6047443Z
EventRecordID 52356
Correlation
- Execution
[ ProcessID] 0
[ ThreadID] 0
Channel Application
Computer GDWX46-01.ds.mot.com
Security

- EventData
TCC.EXE
16.3.55.0
53c146a6
TCC.EXE
16.3.55.0
53c146a6
c0000005
0000000000004dd3
39e0
01d7b3d94aa2f29a
C:\PROGRAM FILES\TCMDV16.X64\TCC.EXE
C:\PROGRAM FILES\TCMDV16.X64\TCC.EXE
75421f50-6d4e-4965-961f-bbf145b1d7e9
 
Last edited:
Sep 27, 2021
7
0
Same here. Until 09/24/2021 my backup script (with copy ... /s/e/u) worked fine, today it only copies 6 files and then crashes with Event-ID 1000.

4NT.EXE from V6 2005 works fine with the script.

Windows 10 V21H1 with current patches.
 
Jun 3, 2008
137
3
Temecula, CA
So it sounds like the most recent Windows 10 patches may have broken it. Any more data points from other users out there who have the latest Windows 10 patches and maybe the most recent version of TCC?
 
Jun 3, 2008
137
3
Temecula, CA
One quick additional data point: I executed the exact same command as the one that crashes, only adding in the /n switch so that it doesn't actually do the copy, and it ran all of the way through, reporting all of the files that would be copied if the copy were to take place, and didn't crash. I don't know if that's helpful, but it can't hurt.
 
Jun 3, 2008
137
3
Temecula, CA
Have you tried the suggestion here? Crash (abort) during COPY on Windows 10
It seems that my virus definitions being out of date may have caused the issue. I ran a definition update that apparently hadn't happened since July, ran a scan, no issues were found, but now the tcc copy works properly. So thanks for pointing me in that general direction, which ultimately resolved the problem for me.
 
  • Like
Reactions: Charles G

Similar threads