TCC IDE Tabs - inactive tabs hard to see


Aug 19, 2008
Last version of V17.

In tests, a fresh install, both tabs are easy to see/distinguish and the active one appears slightly bold in font.

With the same version on two other machines 7 & 10, the inactive tab text is barely visible. Taking my INI from my other machines also causes the problem on the fresh install.

Same INI causes the problem in v19 too.

Any idea what setting would affect tab appearance?


Aug 19, 2008
Well, now seeing the problem everywhere, even when starting with empty .ini files and adding the tabs/button. Registry keys?


May 20, 2008
Syracuse, NY, USA
The button bar supports tabs. You don't use it, I don't use it, but the feature is there.

Ron: Have you tried changing themes? Options / Styles / Theme...
Hmmm! Cool!

I tried every theme. Only "Office 2007 Black" and "Office 2010 Black" had that text in white.

In addition, merely switching themes may not show the correct color text on inactive toolbar tabs. If that color is going to switch between black and white, it does so only after TCMD has been restarted.


Aug 19, 2008
Thanks vefatica for the tip on restarting TCMD. Didn't realize some things don't change to match the newly selected theme until TCMD is restarted.

So, Office 2010 Black is the theme I use. I guess it (and 2007 Black) need to be tweaked to display those characters in black.

The last time I used the tabbed toolbar to any extent was years ago before many themes (if any) were available.


Aug 19, 2008
Yes, both myself and Vince saw the illustrated behavior using both Office Black themes as mentioned above. When changing themes you have to restart TC for some of the changes to take effect. Even after restarting though, I see the white text shown above. Seeing it on Win7 & 10.

It's not critical, but I was hoping it would be an easy thing to fix.

I realize Windows actually draws the controls but TCMD or some 3rd party control you use instigates the control, right?


Aug 19, 2008
Reproducible in a clean Win7x64 VM. The issue arrived with v17. Looks like you unticked the "Luna colors" option and changed the "Appearance set" from VS 2003 to something else. So that explains the change in tab appearance. Given you're using the latest libraries though, seems like a bug in the libraries. Their tabbed toolbar samples don't offer a 'black' theme so I can't fully test the current libraries without getting an eval and building it.

Jan 12, 2014
Switzerland, SO
Same problem here on Win 10 Pro x64 (Clean Install) (with v19.00.39) and Office 2007 black theme ...

EDIT: Problem is with ALL themes (more or less). Even with some others inactive tabs are almost invisible!

The worst is Office 2013 - there inactive tabs are completely invisible.

@Rex: you say, not TCMD is responsible. Okay. Just: this tab function is so practically unusable (at least with some themes) ...

- "Office 2007 Schwarz (black)":

- "Windows 7":

- "Office 2013":

And note: I have NOTHING changed related to such a behaviour after my clean Win 10 installation. So HOW could *I* resolve this? All are default values for Win themes etc.
Last edited:


Aug 19, 2008
@Alpengreis, I suspect you'll find that the Office Black themes are the only ones with the problem. In your Office 2013 example above, if you exit then restart TCMD, you should be able to see the tabs. That's an undocumented quirk in the dynamic switching of themes. Glad to see I'm not the only one seeing this behavior!

As for the responsibility comment by Rex, as a developer I understand his viewpoint. Technically TCMD is indirectly responsible because it's using a 3rd party library to implement some of the TCMD GUI. There are times when updates to these libraries can introduce problems that the library developer and end user could not anticipate or control.

In this case, it seems Rex tweaked the parameters in v17 used to define the tabs in a way that revealed this issue. Aside from undoing that change, his only option may be to wait on the developer of the library he uses to fix their code. Others using this same library are also reporting similar behavioral issues.
Jan 12, 2014
Switzerland, SO
Indeed, after restart I see the tabs (tested with "Windows 7"). I saw something in other thread about restart after change the theme and even about a library problem - just forgot yesterday ...)! My fault!

However: thank you very much and sorry!


Aug 19, 2008
I'm slow to update as I get older :-)

But just wanted to say that Office 2016 Black on v23 works nicely in regards to my issues posted above. Thanks!!!
Similar threads
Thread starter Title Forum Replies Date
Peter Murschall IDE/BDEBUUGER in TCC 22 didn't run Support 7
A Can you set an image file 'tag' with TCC/4NT? Support 2
P PSHELL not working in TCC 26 Support 9
vefatica SCRIPT makes TCC disappear. Support 16
MickeyF TCC suddenly crashing (not TCC's fault) Support 2
Z CMDDebug - TCC unknown command Support 2
rconn News Take Command / TCC / CMDebug / TCC-RT 28.02.17 Support 0
vefatica TCC startup: /IP not honored after /K Support 1
MickeyF TCC crashing when copying multiple files (now resolved) Support 6
C COMSPEC constantly reset to TCC.EXE Support 6
rconn News Take Command / TCC / CMDebug / TCC-RT v28 Released Support 0
C How to? starting TCC/TCMD v25 Support 2
CWBillow TCC and TCMD in Powershell Support 6
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.24 uploaded Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.23 uploaded Support 0
Alpengreis Fixed Crash after copy dialog with big TCC.exception.log Support 5
rconn News Take Command / TCC / CMDebug / TCC-RT v27.01 Build 22 Uploaded Support 0
L FTYPE in TCC, less quirky than in cmd.exe Support 3
V Set path permanently from within TCC? Support 3
DrusTheAxe Runaway TCC.exception.log filling drive Support 5
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.21 uploaded Support 0
Joe Caverly tcc.exception.log Support 3
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.20 uploaded Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.19 Support 0
FreezerBurnt Help making a CMD and TCC compatible batch file Support 7
vefatica SCRIPT ... TCC disappears Support 2
rconn News Take Command / TCC / CMDebug / TCC-RT v27.0.18 Support 0
Jesse Heines Access Denied errors in TCC 27 Support 9
fpefpe How to? tcc inifile (%_ininame) Support 3
M How to? Black TCC Prompt Support 2
D Differences between TCC and CMD with COPY /b Support 4
M Oracle batch OPatch.bat.bat not working in TCC but correctly in CMD Support 5
Jay Sage Extra TCC Tasks Support 6
vefatica Can I turn off the minimize to tray mechanism in TCC? Support 5
N Command execution slows down in TCC Prompt after a while Support 6
R Upgrade TCMD 19 to TCC 26 Support 1
Joe Caverly Set a batch variable (%1 - %n) when TCC is executing a batch file Support 5
samintz How to? Is this doable in TCC? Support 2
rconn News Take Command / TCC / CMDebug / TCC-RT 26.02.41 Uploaded Support 0
D TCC tab detaching & restarting Support 3
Ó Recent git output not shown on TCC Support 1
P Kill all other instances of tcc from a btm batch file Support 2
L Using TCC.exe through an SSH connection Support 3
M TCC color issue in ConEmu Support 4
Alpengreis UTF-8 problem in TCC related to Python Support 7
Alpengreis Python support for 3.8.3 in TCC v26.x? Support 2
rconn News Take Command / TCC / CMDebug / TCC-RT 26.01.40 uploaded Support 0
Peter Murschall TCC V26.01.3x Debugging has problems with Alias /R Support 1
rconn News Take Command / TCC / CMDebug / TCC-RT 26.0.37 Uploaded Support 0
vefatica TCC waits for Office apps Support 4

Similar threads