Command history search is off

May 20, 2008
11,543
104
Syracuse, NY, USA
I did this:

Code:
v:\> history /f"*"

v:\> do i=1 to 20 ( history /a echo %i )

Then I opened the history pop-up and typed "ec" in the search box and scrolled down to "echo 5" and pressed Enter.

1605502716998.png


I got this:

1605502806593.png


It's not just off by 1. Before simplifying the experiment I saw it off by a lot.

You don't have to empty your history to see this. Just open the pop-up, type something in the search box that will have several matches, scroll to one of the matches, press Enter, and see if you get what you asked for. Chances are you won't even get one that matches the search criterion.
 

Bob

Aug 24, 2020
4
1
Is this related to the problem described here? Directory History Window with wildcard search

If so --
This is *very* old code -- turns out Microsoft changed one of the multiple-selection listbox messages at some point in the last few years, which resulted in the first Enter selecting (and disabling) the first line in the listbox. A second enter then returned an empty string.

I have fixed this for the next build.
When[if] there is a next build. :smile:
 
Code:
     _x64: 1
   _admin: 1
_elevated: 1

TCC  26.02.42 x64   Windows 10 [Version 10.0.18363.1139]

This has been a problem for me with the @SELECT function for many months now.

What caught my eye in your post was "The system cannot find the path specified" error message.

I get this quite frequently and randomly, but cannot duplicate it.

That is, I run my .BTM containing @SELECT, it gives the error, I up-arrow and run the .BTM again, and it works as it should.

Joe
 
Similar threads
Thread starter Title Forum Replies Date
T How to? retain command history across reboot? Support 6
R Long commands retrieved from command history have blank line when wrapped Support 20
vefatica Deleting entries in the command history popup? Support 3
David McClelland Command history loosing entries Support 18
M Ctrl-C when using command line history does nothing Support 2
vefatica ESC after recalling a command from history Support 3
vefatica Ctrl-Enter in command history window? Support 8
E Command History not showing on up arrow button Support 8
ehab aboudaya How to? Command Input history for each tab? Support 0
A Ctrl-1 and the command history Support 5
M "History" command not giving me what I want when executed by @Exec... functions... Support 6
nickles Command History Window Support 4
S TCC Command Line Keys - not saving to history? Support 1
R SHRALIAS and command history Support 11
R Command history getting reloaded Support 16
N Command History Failure? Support 3
O Make command history tab-specific Support 2
C history of recent Take Command builds Support 0
Z CMDDebug - TCC unknown command Support 2
F Edit command Support 1
rconn News Take Command / TCC / CMDebug / TCC-RT 28.02.17 Support 0
old coot LEAVE appears to affect command-line arguments Support 11
J VDESKTOP command Support 3
old coot tee command cancels colors Support 33
Dmitry L. Kobyakov How to? How to remove the record of the old version of the Take Command? Support 9
D Can alias pass parameters to for command? Support 3
samintz How to? Search for %(command) in Help? Support 1
T VIEW only works from command line Support 14
rconn News Take Command / TCC / CMDebug / TCC-RT v28 Released Support 0
T Take Command 28: Lua reports version 5.4.0 (5.4.3 expected) [SOLVED] Support 1
Jay Sage WAD Possible Bug With OPTION Command With @FILE Support 5
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.24 uploaded Support 0
J Take command does not start on Windows 10 Support 3
vefatica `Back quotes` - command line vs. batch file Support 5
Jay Sage WAD Failure of Alias Command with /Z Option Support 14
Phileosophos Is there any way to open the Take Command options dialog from the command line? Support 8
Phileosophos Command-line Editing Shortkeys That Fail Support 6
fpefpe How to? free (internal) command Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.23 uploaded Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT v27.01 Build 22 Uploaded Support 0
Jay Sage Bug With Flow Control and/or Command Grouping Support 2
GermanDirk How to? EVENTLOG Command with simple User Rights not functional Support 4
Jay Sage Take Command Is Too Fast! Support 4
Jay Sage Comparison of IF with Command Group and IFF Support 6
D Open Windows 10 Photos app from command line Support 11
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.21 uploaded Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.20 uploaded Support 0
U Can not get/start Take Command gui Support 1
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.19 Support 0
S Increasing Font Point Size in Command Tabs Support 2

Similar threads