TCC LE crashes without any info after recent windows updates

Apr 28, 2020
2
0
TCC LE (at least versions 13 and 14) has recently started crashing / disappearing after short while, like after 5-15 minutes even when it's just idle. There is no error popup or anything, it just disappears. In rare cases the application stays open but you can't write anything into it anymore.

I tried to debug the issue using Process Monitor in case it's a permission or missing / wrong dll version or something, but it doesn't show anything useful. When this happens, the first things seen there is the process trying to look for pdb files, which I assume means it's already crashed.

This has now been confirmed with 3 different Windows Server 2012 R2 standard servers. All started crashing after windows updates were installed. Unfortunately I don't know what was the exact update or time that started causing this, but the info I got was that it must have started 1-2 months ago. Haven't noticed anything similar in Windows 10.

Installed TCC 26 to test if it has the same problems -- it works just fine in the same server, and even after installing it, TCC LE 14 keeps crashing.

Here's a picture and crash happened at 10:27:

tcc.png
 
Oct 8, 2021
5
1
This started happening to me about a week ago. The issue seems to be related to Windows Defender.
In my experience, the problem happens only with TCC/LE x64. The x86 version seems to work fine.

The following thread may be relevant to your situation:
 
Jul 12, 2022
1
0
I'm having this exact same problem and have tried multiple versions. I essentially have a choice:

use TCMD

or have no windows defender for the entire machine

I was thinking about purchasing a new version but i cannot possibly fork over money for a product that crashes out every time I try to copy more than 4-8 files.

Turning off ipv6 -- no help

Making windows defender IP exceptions to allow ALL inbound and outbound connections to local 192.168.x.x IP addresses -- no help

Making windows defender program exceptoins to allow all inbound/outbound connections from TCC.EXE -- no help

turning defender on and off? instantly everything works.
 
Oct 8, 2021
5
1
Did you try the x86 version? I had exactly this same problem (TCC/LE closing while copying files but only with Windows Defender enabled), and it was solved completely when I switched from x64 to x86.
 

Similar threads