Fixed TC crashes with a certain batch file

Apr 10, 2013
hello all,

I've just begun to evaluate this product (latest version 15.00.33) but things immediately went bad. I have tried to load a quite long batch file that I built some months ago using a standard editor and countless hours of edit and try... (sob).

The file is loaded into the editor/debugger, but as soon as I scroll down to about 1/3 of the file length (it doesn't matter if I use the mouse or the keyboard) Take Command simply crashes (ProgramName has stopped to work...). I attach an image of the error and a copy of the event recorded in the Windows' event database (at the bottom). The environment is:

Computer: Fujitsu Siemens Esprimo P5925 dual core x64
OS: Windows 7 Ultimate x64 with all updates

I have tried to install both x86 and x64 versions (one at a time, of course), but the error is the same with both versions.

If it can be useful, I can upload the batch file in the next reply.

Thank you

- <Event xmlns="">
- <System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<TimeCreated SystemTime="2013-04-10T08:04:33.000000000Z" />
<Security />
- <EventData>
<Data>C:\Program Files\JP Software\Take Command x64 15.0\IDE.EXE</Data>
<Data>C:\Program Files\JP Software\Take Command x64 15.0\SciLexer.DLL</Data>
Please email the batch file to

Also, if this is the 32-bit version of Take Command, you should have a file called IDE.GPF, which will usually be in the same location as your TCMD.INI file. (On Win 7 or Win 8, it's usually in \users\yourname\appdata\local\jpsoft.) Please send that as well.

batch file sent: CompilePackages.bat into a zipped file.

Similar threads