How to? shortcuts and batch files

Oct 18, 2008
345
2
As it turns out, after I installed take command, I probably ran the btm file tccbatch.btm or tcmdbatch.btm and probably replied “yes” to have take/tcc execute *.bat, *.cmd and *.btm files. I don’t know if it is “best practice” when creating a “shortcut” (file) to specify as the “target” a “bat” file or precede the bat file with cmd.exe /c

As it turns out the shortcut that the (new) google drive creates does just that, and take/tcc seems to have an issue executing that batch file.

Is there a way to revert the value of “batfile” (and cmdfile) (via ftype command) to the default value before tccbatch.btm or tcmdbatch.btm executed? Thanks
 

samintz

Scott Mintz
May 20, 2008
1,533
21
Solon, OH, USA
The tccbatch.btm file that is distributed with TCC/TakeCommand has the option to make CMD the default handler of BAT and CMD files.
If your run tccbatch /U it will ask if you want to do that.
 
Oct 18, 2008
345
2
thanks for your reply --- I must have an old version of tccbatch --- is a current version available to download?
 

samintz

Scott Mintz
May 20, 2008
1,533
21
Solon, OH, USA
What version are you running? These commands will restore defaults:
Code:
ftype batfile="c:\windows\system32\cmd.exe" /c "%%1" %%*
ftype cmdfile="c:\windows\system32\cmd.exe" /c "%%1" %%*
 
Oct 18, 2008
345
2
thanks for the info --- I am running the free tccle -- I thjink the last version was 14 and tcmd v19
 

Similar threads