How to? ipconfig output in current window

Apr 26, 2011
San Francisco
When I run just ipconfig (it's on the PATH) at TC command line (Windows 10, TCC 21), it runs in a separate window (titled C:\WINDOWS\system32\ipconfig.exe ) then closes, as if I were double-clicking it in File Explorer. Is that normal?

Workaround is to use
cmd /c ipconfig
which shows ipconfig's output in the current TCC or TakeCommand window

- Scott B.
Apr 26, 2011
San Francisco
Thanks for the replies, and my apologies for delay in getting back on this.

Maybe my site has some weird security restriction. This is not a big problem for me, just puzzling. Some clues below in case you want to take a look.

FYI, I tried running ipconfig six ways. (Windows 10 Enterprise, 64 bit, ver, 1607; TCC 21.01.52 x64).
1. CMD stand-alone window or CMD window within a TC tab: ipconfig writes to screen as expected.

2. What I originally reported:Type "ipconfig" in a TCC console window (stand-alone in TCC, or in a tab in TakeCommand). I have no alias for ipconfig, but it is on my PATH; output of 'which' is:
> which /a ipconfig
ipconfig is an external : C:\WINDOWS\system32\ipconfig.exe
Executes ipconfig in a new window which then disappears.​

3. Defined a TC Tool Bar Button to start in new window, with command "%SystemRoot%\System32\ipconfig.exe", on running I get a Take Command 21 error box stating:
Access is denied.

4.Button with command "%SystemRoot%\System32\cmd.exe %SystemRoot%\System32\ipconfig.exe":
I get to a CMD tabbed console window, no apparent execution of ipconfig.

5. Button with a "/c", command "%SystemRoot%\System32\cmd.exe /c %SystemRoot%\System32\ipconfig.exe":
I get a tabbed window, presumably CMD, that executes ipconfig and then disappears.

6. .btm Batch file with same as #4 (no "/c") on 1st line, and pause on 2nd. It echoes the first line, then goes to a CMD prompt in the TCC window, which shows the windows version like CMD normally would, then next line is a CMD prompt, where the prompt is a single '[' (left bracket), at which I can run CMD commands, including ipconfig, normally. On typing EXIT, I get to the pause command in the batch file.

I tried a bunch of other apparently-console programs within System32, under TCC; all worked OK except chkdsk.exe, extrac32.exe, ipconfig.exe, all of which executed in a new window and disappeared. Security permissions on all the executables seemed the same.

Thanks again -- any suggestions welcome.

- Scott B.

Similar threads