How to? ini directives on the command line

Oct 18, 2008
345
2
I want to override the “stdcolors” directive in my ini file and use the command line option

//stdcolors=

but the syntax for that directive is “color on color” and when using the command line option space are not permitted, I would like to set it as if was not set in the ini file at all. I tried stdcolors=default but that did not work. Is “stdcolors” one of the directives that is not setable on the command line?
 
May 20, 2008
11,783
118
Syracuse, NY, USA
Spaces are OK here, but a change doesn't last long. 112 is 0x70 which is bla (0x00) on whi (0x70).

1640717958160.png
 
Oct 18, 2008
345
2
umm .... it seem that when "stdcolors" is not in the ini file the numeric value is "0" but

//stdcolors=0 does not set it to the default value
 
Oct 18, 2008
345
2
Hello — Thanks for the info — in my case, it seems that if “Stdcolors” is on the cmdline, ie //stdcolors= or in the inifile, then tcc will set the noted value. In my case I don’t want tcc to set any color — ideally //stdcolors=none or “default” would do what I want to happen, is for tcc not to set any color — so my solution is to have an alternative ini file with any of the color directives comments out — which is the outcome I am looking for
 
May 20, 2008
11,783
118
Syracuse, NY, USA
In the OPTION dialog, Windows tab, "Default" is a color option for input, output, error, and selected ... both foreground and background. Do they not do what you want?
 
Oct 18, 2008
345
2
Hello — Thanks for your reply.

I guess setting the value via option would work, but that would change the invocation of tcc in all cases. I been trying “windows terminal” and for the color option set in “wt settings” Tcc can not issue and command to set the color, so an alternative INI file for WT seems to do what I want — As noted an option of “Stdcolors=none” would be for the most part if “stdcolors” was not ever in the INI file, or if specified via //stdcolors=none” to skip if it is found in the ini file. Thanks again
 
May 20, 2008
11,783
118
Syracuse, NY, USA
There are several things that don't (and for many, won't) work in Windows Terminal. But if you're concerned with colors, one thing that you can do is specify as RGB (24-bit color) the 16 colors in the usual palette along with 3 more, namely the default foreground, default background, and cursor color. I've attached a BTM that will do that for any of the 9 themes built-in in Windows Terminal. You can actually remap the 16-color (with 24-bit colors) palette in the curent Windows console, but you can't specify new defaults (as above). It can get a little goofy when there's a conflict between the default fore/back and palette-specified fore/back.
 

Attachments

  • wtscheme.zip
    1.2 KB · Views: 20
May 20, 2008
11,783
118
Syracuse, NY, USA
Thanks -- that will work for me
I hope it helps. I was mistaken when I said earlier that the sequences for default foreground, default background, and cursor color didn't work in the current Windows 10 console. But a conflict arises when those colors are not in the 16-color palette. A good example is the Campbell Powershell theme. The defauly background color is a blue (rgb:01/24/56) which is not in the 16-color palette. So what the console thinks is "default" (^e[0m) and what TCC thinks is "default" (a pair of palette colors) may be different. I don't know why that is not a problem in Windows Terminal.
 

Similar threads

C
Replies
15
Views
3K
Support
CSGalloway@nc.rr.com
C