IDE crashes every time

May 20, 2008
11,519
102
Syracuse, NY, USA
With any BAT or BTM, as soon as I press "Start" or "Start without debugging" IDE.EXE crashes (... has stopped working ...). There's no ide.exception.log. Here's what Windows says.
Code:
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   IDE.EXE
  Application Version:   19.2.38.0
  Application Timestamp:   56abd90a
  Fault Module Name:   IDE.EXE
  Fault Module Version:   19.2.38.0
  Fault Module Timestamp:   56abd90a
  Exception Code:   c0000005
  Exception Offset:   00019605
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:   1033
  Additional Information 1:   0a9e
  Additional Information 2:   0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:   0a9e
  Additional Information 4:   0a9e372d3b4ad19135b953a78882e789

If I choose to debug, I get "Unhandled exception at 0x00369605 in ide.exe: 0xC0000005: Access violation reading location 0x02020222".

Although the locations differ, the two reports above (Windows and VS2010) are from the same crash. The location is different each time! The 0x02020222 is the same each time.
 
May 20, 2008
11,519
102
Syracuse, NY, USA
I tried it after TCC was started with "/ip" ... same result.

I also tried it after TCC was started with "/ii" ... the same result and also, after the file was loaded and nothing was done to cause the crash, I get, in the console:
Code:
v:\> bdebugger foo.bat
TCC: (Sys) The system cannot find the file specified.
 ""
 
May 20, 2008
11,519
102
Syracuse, NY, USA
Cleaned the registry ... crash was gone ... added "Start without debugging" button to the debug toolbar ... after restarting IDE the crash was back.

I'm not using TCMD. Start TCC with "/ii", then "BDEBUGGER any_file". The message appears in the console.
 
May 20, 2008
11,519
102
Syracuse, NY, USA
P.S. Then remove the "Start without debugging" button and restart IDE. The crash is still there. The same thing happens on any customization of the tool bar (also tried "Show next statement" and "Select all").
 

rconn

Administrator
Staff member
May 14, 2008
12,404
152
Still not reproducible here, at least with the x64 version. I'll try it with the x86 build later today. (Though that would point to a Microsoft bug, which would also explain why you're not seeing a log file.)

And I don't understand how you could "remove the Start without debugging" button if the IDE is crashing when you start.
 
Similar threads
Thread starter Title Forum Replies Date
cgunhouse IDE Crashes on Exit Support 6
old coot Is there a consistent way to do a single-key repeat search in the edit/debug IDE? Support 5
Kachupp IDE watch references Support 11
T Thanks for the assistance with IDE vs Bdebugger Support 3
vefatica IDE external command syntax color? Support 1
K_Meinhard Small problem in german IDE 26 Support 3
vefatica IDE - when breakpoint is on a blank line? Support 3
Peter Murschall IDE: After undocking the command expansion Window is offended Support 2
Peter Murschall IDE: Ctrl-W is a Harakiri Command ! Support 23
Kachupp ide/bdebugger Support 17
rps IDE/BDEBUGGER ? Support 1
vefatica IDE.EXE's command line? Support 19
Peter Murschall IDE: RTL with non-English resources-problem is back in Build 28 Support 4
Peter Murschall v24 IDE/BDEBUGGER won't start Support 9
vefatica IDE stuck on "Insert tabs as spaces" Support 0
Peter Murschall IDE/BDEBUUGER in TCC 22 didn't run Support 7
T Fixed Problem with use of Batch parameters in the IDE Support 1
T Fixed IDE locks up if edit window for running batch is closed Support 6
Peter Murschall IDE destroys Text on Ctrl-U/Ctrl-Shift-U Support 12
C BDEBUGGER/IDE crashing Support 1
vefatica Monospace font in IDE? Support 3
R TCC IDE Tabs - inactive tabs hard to see Support 14
vefatica IDE crashing Support 11
vefatica Why doesn't "IDE %_ININAME" work? Support 4
vefatica IDE's dynamic help ... Support 0
vefatica Contuing IDE gripes Support 11
vefatica WAD IDE, output window to foreground Support 3
vefatica Fixed IDE weirdness Support 3
vefatica IDE double-click select? Support 29
vefatica Doesn't IDE auto-indent? Support 3
T bdebugger / ide usage confusion Support 14
vefatica Fixed Font corruption in IDE Support 3
vefatica IDE status bar row/column? Support 0
vefatica An IDE anomaly Support 2
T Associating BTM files with IDE results in DOS box Support 33
S WAD IDE /C does not accept truename of future file Support 13
S How to? Is it possible for the IDE to start without plugins? Support 3
S Documentation "HELP IDE" - missing reference Support 0
Mordachai Fixed Closing TCMD while IDE + Help Open = Crash Support 7
jwiede ide.exe not launching? Support 13
F No ide.exe or tcmd.exe files - Win7 64bit Support 5
T Syntax highlighting in the IDE Support 8
Frank watch an array variable in ide/bdebugger Support 2
Peter Murschall Is IDE forbidden in TCSTART.BTM ? Support 4
rfaquino TCMD 14.0 IDE Crash Support 7
epement differences in IDE/debugger between v12 and v14 Support 1
Alan Strader Take Command IDE/Debugger has stopped working Support 5
J Fixed IDE search keys don't work in TCMD 13.01.32 Support 3
vefatica IDE watch window Support 1
Stefano Piccardi IDE unexpectedly exits inside this batch file Support 17

Similar threads