Hidden console doesn't close

May 20, 2008
11,798
118
Syracuse, NY, USA
On Tue, 17 May 2011 09:36:44 -0400, Charles Dye <> wrote:

|Do you by any chance have any plugins loaded? A few of mine temporarily change the console title as a kludgey method of finding the window handle.

It happens (without fail) with or without plugins. Necessary conditions for the
error are

1. existing (possibly empty) TCEXIT.BTM (with path to it in TCMD.INI)
2. "UppdateTitles=No"
3. TITLEPROMPT set
4. TITLE not used in TCEXIT.BTM
 
May 20, 2008
11,798
118
Syracuse, NY, USA
1. existing (possibly empty) TCEXIT.BTM (with path to it in TCMD.INI)
2. "UppdateTitles=No"
3. TITLEPROMPT set
4. TITLE not used in TCEXIT.BTM

Now, with (virtual) Vista ... conditions as above ... when I "X" TCMD, it takes 5 seconds before TCMD and its TCC exit ... not (quite) long enough to elicit the "Windows cannot end ..." message (as in XP) but still not right.
 
May 20, 2008
11,798
118
Syracuse, NY, USA
1. existing (possibly empty) TCEXIT.BTM (with path to it in TCMD.INI)
2. "UppdateTitles=No"
3. TITLEPROMPT set
4. TITLE not used in TCEXIT.BTM

Now, with (virtual) Vista ... conditions as above ... when I "X" TCMD, it takes 5 seconds before TCMD and its TCC exit ... not (quite) long enough to elicit the "Windows cannot end ..." message (as in XP) but still not right.

And, on either system, if during the 5-second delay I try to start (by any means) a stand-alone TCC, the new TCC starts (according to TaskMgr) but does not become visible until the 5 seconds expires.
 

rconn

Administrator
Staff member
May 14, 2008
12,425
153
1. existing (possibly empty) TCEXIT.BTM (with path to it in TCMD.INI)
2. "UppdateTitles=No"
3. TITLEPROMPT set
4. TITLE not used in TCEXIT.BTM

Now, with (virtual) Vista ... conditions as above ... when I "X" TCMD, it takes 5 seconds before TCMD and its TCC exit ... not (quite) long enough to elicit the "Windows cannot end ..." message (as in XP) but still not right.

Not reproducible here.
 

Similar threads