By registering with us, you'll be able to discuss, share and exchange private messages with other members of our community.

SignUp Now!

WAD dir "ftp:// ..." fails in TCC 15

*dir /a:-d /[!.*] /k /m /o-d "ftp://ftp.jpsoft.com/plugins/" > x.txt

works in TCC v 14, but fails in TCC v 15 under Windows XP Pro SP3.

The error is
TCC: (Sys) The system cannot find the file specified.

It's not just ftp.jpsoft.com; it happens with any ftp:// target.
It's OK here but Win7 did ask if I wanted to allow TCC to do it. Do you have any firewall involved?

v:\> dir /a:-d /[!.*] /k /m /o-d "ftp://ftp.jpsoft.com/plugins/" > jpplugs.txt
v:\> type jpplugs.txt
2011-03-05  00:00        103,381  inputloop.zip
2011-03-05  00:00              0  index.html
2011-03-05  00:00      2,504,430  fedutils9.zip
2011-03-05  00:00          12,199  everything.zip
2011-03-05  00:00          45,472  event11.zip
It's OK here but Win7 did ask if I wanted to allow TCC to do it. Do you have any firewall involved?

Versions 14 and 15 running under the same conditions, with AVG 2013 free edition. My web browser (Firefox) is also able to open the remote directory without a problem.
Not reproducible here -- tried it on 4 systems without any problems. (That code has not changed in v15.)

I suspect something on your system is blocking TCC -- did you check your Windows Firewall settings?
Yes, I checked the firewall settings -- it's AVG Free edition. Leaving the settings alone, I can do this running TCC v 14, but it fails in TCC v 15, without changing any settings.
Turning the firewall off, it still works in TCC v14, and still fails in TCC v15.
Further tests:

Running TCC v 15 --

"%_tccpath\..\TCMD14\TCC.EXE" /c *dir /a:-d /[!.*] /k /m /o-d "ftp://ftp.jpsoft.com/plugins/" > x.txt


Both TCC 14 and TCC 15 use the same TCSTART.BTM .

I'm stumped.
I found that starting a new instance of TCC with
"%comspec" /i /c *dir  ....(and the rest)
works. So, I conclude that there must be some variable, plugin, or function that's getting in the way and causing the error.
So, Rex, you can remove the Bug tag from this topic if you wish.
Unchecking Passive FTP in the Option > Internet dialog seems to have helped.

Similar threads