Checking for UNC path readiness

Jun 3, 2008
137
3
Temecula, CA
In TCC version 16, @ready[\\myserver\c$] returned 1 if myserver could be reached on the network, even if it hadn't been authenticated yet. Now in TCC version 28 (the latest), it returns, "The parameter is incorrect." Why the change, but more importantly, is there a way I can query if a UNC path is reachable, and that's compatible with both V16 and V28?
 
May 20, 2008
11,840
120
Syracuse, NY, USA
How about %@IF[exist \\myserver\c$,1,0].

My old computer died so I can't test it and I can't go back beyond TCC v24. :confused:
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,576
97
Albuquerque, NM
prospero.unm.edu
I have a few older versions here, and can replicate the problem. It looks like whatever changed, it happened in v22 (early 2018). I don't see anything about @READY in the What's New for v28.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,576
97
Albuquerque, NM
prospero.unm.edu
I take it back. @READY with a UNC name worked for me once. Now it gives the same error message.

That line about not supporting UNC drives appears at least as far back as Take Command v11.
 
Jun 3, 2008
137
3
Temecula, CA
I take it back. @READY with a UNC name worked for me once. Now it gives the same error message.

That line about not supporting UNC drives appears at least as far back as Take Command v11.
Well, I didn't RTM back in v16, and it worked, even if it wasn't supported. :-) Obviously I can't complain about something not working that was unsupported!
 

Similar threads