BUG: 'dig' of bind 9.6.0 P1 crashes when used with TC10

Jul 7, 2008
35
0
Texas, USA
'dig' of bind 9.6.0-P1 Windows binary distribution (downloadable here) crashes when used from within TakeCommand 10 (I'm using the latest version, 10.00.67).

It doesn't crash when used from regular windows command prompt (XP Pro SP3). When using dig from bind's previous production release 9.5.1-P2, it won't crash.

Using dig without any parameters other than the domain name (i.e. 'dig somedomainname.com') doesn't cause crash every time but, for example, 'dig somedomainname.com a' does it every time.

Whether this is a bug in dig.exe or in TC/TCC, it only presents itself with TC/TCC prompt.
 

dim

Dimitry Andric
May 31, 2008
205
1
Netherlands
BUG: 'dig' of bind 9.6.0 P1 (production release) crashes when used with TC10

On 2009-05-13 08:25, Ville wrote:

> 'dig' of bind 9.6.0-P1 Windows binary distribution (downloadable here (https://www.isc.org/downloadables/11)) crashes when used from within TakeCommand 10 (I'm using the latest version, 10.00.67).
>
> It doesn't crash when used from regular windows command prompt (XP Pro SP3). When using dig from bind's previous production release 9.5.1-P2, it won't crash.

I have no problems here with dig 9.6.0-P1, under TC 10.00.67. Since
dig, and the other bind tools, are quite sensitive to the PATH setting,
can you please check if the PATH is not different for your cmd.exe and
tcc.exe instances?
 
Jul 7, 2008
35
0
Texas, USA
The paths did differ, but it didn't seem to be the cause for the problem (I made the TC path exactly the same as in the cmd.exe, but the crash still occurs with 9.6.0-P1).

It's possible, though, that something in my system is causing the problem; I'll test the same on few other systems tomorrow.
 
Oct 29, 2008
90
0
The paths did differ, but it didn't seem to be the cause for the problem (I made the TC path exactly the same as in the cmd.exe, but the crash still occurs with 9.6.0-P1).

It's possible, though, that something in my system is causing the problem; I'll test the same on few other systems tomorrow.
I just upgraded my copy of dig, and don't have a problem. One thing you might check is how many copies of libeay32.dll you have floating around. I recall having a problem in something else because it was picking up the wrong version of libeay32.dll.
 

rconn

Administrator
Staff member
May 14, 2008
12,404
152
BUG: 'dig' of bind 9.6.0 P1 (production release) crashes when used with TC10

Ville wrote:

> 'dig' of bind 9.6.0-P1 Windows binary distribution (downloadable here (https://www.isc.org/downloadables/11)) crashes when used from within TakeCommand 10 (I'm using the latest version, 10.00.67).
>
> It doesn't crash when used from regular windows command prompt (XP Pro SP3). When using dig from bind's previous production release 9.5.1-P2, it won't crash.
>
> Using dig without any parameters other than the domain name (i.e. '*dig somedomainname.com*') doesn't cause crash every time but, for example, '*dig somedomainname.com a*' does it every time.
>
> Whether this is a bug in dig.exe or in TC/TCC, it only presents itself with TC/TCC prompt.

Not reproducible here.

It cannot be a bug in TCC, as it would require a matching (and
catastrophic) bug in Windows for TCC to affect a separate process.

It's going to be either a bug in dig.exe (manifested by a slightly
different environment or other setup configuration between your CMD and
TCC sessions), or a third-party app crashing dig (i.e., by injecting a
dll into dig's address space).

Rex Conn
JP Software
 
Jul 7, 2008
35
0
Texas, USA
Rex & others, thanks for the responses. I'll debug further on my system, concentrating on the environment differences between TCC and CMD.
 
Jul 7, 2008
35
0
Texas, USA
Hmm.. after upgrading from 10.0.67 to 10.0.68 the problem with latest dig crashing seems to have gone away. Did something that could've affected this issue change in TCC, or was it perhaps just the reinstallation that made the difference?
 
Similar threads
Thread starter Title Forum Replies Date
Dick Johnson v28 Cosmetic Bug Support 0
Jay Sage WAD Possible Bug With OPTION Command With @FILE Support 5
R strange bug? Support 7
Jay Sage Bug With Flow Control and/or Command Grouping Support 2
M Server 2019 Bug with @execstr? Support 14
R bug _ypixels in BDEBUGGER Support 6
E Fixed Bug with DIR /Z displaying descriptions Support 8
E Text copy bug Support 1
x13 SETARRAY /Z bug Support 6
Gamegod ffind bug with chinese Support 2
Dick Johnson cdd - is this a bug or a feature? Support 7
P "Set" command behavior - a bug? Support 3
nikbackm TCC 20 variable expansion bug Support 6
gentzel Bug launching external commands in 20.11.43 Support 11
R Is this a bug in SETARRAY? Support 2
M Windows Installer bug? Support 4
vefatica @SCRIPT bug persists Support 4
M Little bug, big consequences .. Support 6
fishman@panix.com Once again the Can't Install bug bites... Support 2
gentzel Fixed dirs +n bug in 20.0.12 x64 Support 2
M Bug in Windows 10, when adding symbol to task bar Support 6
Alpengreis [Bug?] View (V) Prefs Error (TC 18.00.27 x64) Support 4
D WAD Minor Post Installation Bug in V18 Support 1
I Possible Bug: History /n Returns Nothing Support 3
samintz WAD Weird REN bug Support 6
Jay Sage WAD Possible Bug in Batch Parameters Support 7
G Bug? TCC 16.03.55 Console Palette Support 4
S Return of FTP copy bug in 16.02.48 Support 12
S XenForo bug Support 3
D TCMD16 Delete Toolbar Button bug Support 7
keithg1964 WAD 16.0027 Alias /rz bug Support 8
rfaquino WAD Apparently a bug when expanding environment variable %ProgramFiles(x86) Support 2
T Documentation @LINE[CON,n] @LINES[CON] not documented (bug?) Support 4
H TIMER bug Support 4
G Fixed @REREPLACE bug Support 15
G WAD PDIR @IF bug, @WORD bug Support 8
T Bug in TCMD but not in TCC Support 8
M WAD A complaint regarding a very irritating TCC installation behavior... (Bug?) Support 4
nickles Renaming bug? Support 9
nickles Redirect bug? Support 4
nickles UrlDecode() bug? Support 3
P WAD Bug in TC v 13.03 build 39 x64 Support 1
S Debug feature bug? Support 17
Roedy CDD /S bug Support 3
J TCCLE 12.11 dirhistory bug Support 1
S MOVE from FTP directory to another FTP directory - bug?? Support 2
T Bug in variable expansion Support 4
M An undocumented limitation and an associated minor bug... Support 1
M High-Precision arithmetic bug... Support 1
nickles REN bug Support 11

Similar threads